Author Topic: RFM69W receiver hangs  (Read 1187 times)

eddy6098

  • Newbie
  • *
  • Posts: 11
  • Country: de
RFM69W receiver hangs
« on: January 16, 2017, 02:52:39 AM »
Hi All,
I am basically using two RFM69W modules for trasmitting and receiving data every sec.
It is observed that the transmission takes place every SEC but the receiver node hangs most of the time and the packets are lost in this way (sending data of 40 bytes).
How do I debug this problem? Is there any fix ?
Regards,
Eddy

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6377
  • Country: us
    • LowPowerLab
Re: RFM69W receiver hangs
« Reply #1 on: January 16, 2017, 04:28:59 PM »
What mcu/hardware?
What library?
What sketch?

eddy6098

  • Newbie
  • *
  • Posts: 11
  • Country: de
Re: RFM69W receiver hangs
« Reply #2 on: January 17, 2017, 02:26:31 AM »
Hi Felix,
I am using the hardware from Hope RF (RFM69W) on a RaspberryPi 3 (2 RPi) (for intial tests)
Library from low power labs. Without ACK
Followed the connections from this link (http://rdepablos.merlitec.com/mixed/rfm69-library-for-raspberry-pi)

Thanks,
Eddy
« Last Edit: January 17, 2017, 02:35:46 AM by eddy6098 »
Regards,
Eddy

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6377
  • Country: us
    • LowPowerLab
Re: RFM69W receiver hangs
« Reply #3 on: January 17, 2017, 07:59:30 AM »
Wait, that's not my library?!

eddy6098

  • Newbie
  • *
  • Posts: 11
  • Country: de
Re: RFM69W receiver hangs
« Reply #4 on: January 17, 2017, 08:20:58 AM »
Hi felix,

For connections to the Rpi I reffered to the above link.
But for the library, followed this (https://github.com/LowPowerLab/RFM69 ). This one is right?
Regards,
Eddy

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6377
  • Country: us
    • LowPowerLab
Re: RFM69W receiver hangs
« Reply #5 on: January 17, 2017, 08:26:54 AM »
My library is for AVRs not for RaspberryPi.

eddy6098

  • Newbie
  • *
  • Posts: 11
  • Country: de
Re: RFM69W receiver hangs
« Reply #6 on: January 17, 2017, 08:34:16 AM »
Yes I know this, I have ported your library for Raspberry Pi.
Everthing works fine in the first few minutes and then there are packet losses periodically (roughly 15 secs every time ).
If you have any idea on how to debug this problem would be helpful
Regards,
Eddy

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6377
  • Country: us
    • LowPowerLab
Re: RFM69W receiver hangs
« Reply #7 on: January 17, 2017, 08:39:50 AM »
Some folks in the forum (I recall joelucid) reported the Pi is noisy and will affect the RFM69.
Otherwise I don't know how to further advise.

eddy6098

  • Newbie
  • *
  • Posts: 11
  • Country: de
Re: RFM69W receiver hangs
« Reply #8 on: January 17, 2017, 08:43:27 AM »
Thanks for the info felix :)
Regards,
Eddy