Author Topic: RFM69CW Module: RFM69 lib lets Arduino crash, but RH_RF69 runs  (Read 1199 times)

RTFM

  • Newbie
  • *
  • Posts: 6
RFM69CW Module: RFM69 lib lets Arduino crash, but RH_RF69 runs
« on: December 04, 2015, 07:39:26 AM »
Hello

Because of good reputation and functionality, I used :
LowPowerLab/RFM69  library
from
https://github.com/LowPowerLab/RFM69
and I tried to run simple struct_send / struct_reveive examples.
To do this, I used two different "Original" Arduino UNO from Italy on 2 different breadboards.
Nearly each send /receive causes Arduino to restart or to hang.
To avoid power issues, both the modules got their own power supply,  Arduno independet.
No help.
So not clear -  Arduino defective? Modules wrongly wired?
In a different try I used Radioheads RH_RF69 from here:
http://www.airspayce.com/mikem/arduino/RadioHead/classRH__RF69.html
It works well.
OK - for now I have an intermediate solution.
From that point of view, neither power supply nor cabling are to blame.
However - something is wrong and I really would like to know what bofore I implement my "Mesh".
Does the RFM69  library really run with simple Arduino Uno - or with Moteino only?
Any ideas what I have to check additionally? 

Thanks!
RTFM

emjay

  • Full Member
  • ***
  • Posts: 119
  • Country: nl
Re: RFM69CW Module: RFM69 lib lets Arduino crash, but RH_RF69 runs
« Reply #1 on: December 04, 2015, 05:22:18 PM »
@RTFM,

How are you changing logic levels from the Uno (5v) to the RF Module (max 3.6v)?

RTFM

  • Newbie
  • *
  • Posts: 6
Re: RFM69CW Module: RFM69 lib lets Arduino crash, but RH_RF69 runs
« Reply #2 on: December 06, 2015, 04:24:18 PM »
Hi,

By 1k-2.2k voltage divider, each for  for NSS, MOSI, SCK/CLK.

RTFM