Author Topic: Is it possible to install older version of Moteiono IoT framework on Pi Zero W?  (Read 238 times)

SanG

  • Newbie
  • *
  • Posts: 43
Hello,

I am just wondering if I can install an older version (v8.10) of Moteino IoT framework on Pi Zero W. For some reason, the Pi is heating up excessively and eventually got frozen with the latest version v9.10. I also noticed that every time I opened up the browser to access Moteino gateway dashboard, the %CPU and %MEM go very high around 90%. The same thing happened in Pi 3 and that's why I reinstalled its working image with v8.10 framework. However, I don't have the image of Pi Zero W with that version. Any help will be appreciated.

Thank you.

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6279
  • Country: us
    • LowPowerLab
Is this heating/freezing on Pi zero?

SanG

  • Newbie
  • *
  • Posts: 43
Pi Zero W

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6279
  • Country: us
    • LowPowerLab
OK thanks but Pi Zero is not something I would consider for this application, let alone offer support for it. Its slow as dirt. Maybe good enough for blinking LEDs.

SanG

  • Newbie
  • *
  • Posts: 43
Oh, I see. Thank you for your suggestion, Felix. I will think of switching it to Pi 3 or 4 soon. However, I still would like to know if it is possible to install an older version (such as v8.10) of Moteino IoT framework on Pi Zero W or even on Pi 3. If yes, could you please guide me how can I do this.

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6279
  • Country: us
    • LowPowerLab
Others reported Zero working with older versions.
But I dont know the answer because I never used a Zero and distributions have changed.

redpoll123

  • Newbie
  • *
  • Posts: 21
  • Country: us
I have a Pi Zero W running Gateway version 9.0.0 and been working OK for 6 months.
It is collecting and reporting low rate data from 3 Moteino nodes.
Depending on your requirements, as Felix suggested, you might need something with more horsepower.

SanG

  • Newbie
  • *
  • Posts: 43
Thank you for sharing your experience redpoll123. It's great to hear that the Pi Zero W has been running Gateway version 9.0.0 for 6 months without any issue. But mine is version 9.1.0 and I don't know if that will make any difference. But I am not only talking about Pi Zero W here, this version somehow didn't work for Pi 3 Model B as well. I encountered similar heating and hanging issue with this Pi as well especially when trying to open the chromium web browser locally or any browser (Google Chrome, Firefox, Internet Explorer) remotely via SSH. So I would like to know if anyone knows how to install an earlier version (such as version 8.10 or maybe version 9.0.0) of Moteino IoT Framework on any Pi (Pi 3 or Pi Zero W). I am not sure if installing this version will solve my issue, but at least I would like to give it a shot. When I install using the following command,
Code: [Select]
sudo wget https://raw.githubusercontent.com/LowPowerLab/RaspberryPi-Gateway/master/.setup/gatewaysetup.sh
sudo bash gatewaysetup.sh && sudo rm gatewaysetup.sh
it only installs the latest version. Is there a different line of code or different location address to install the earlier version or is it simply not possible?