Author Topic: Ghost nodes  (Read 229 times)

gigawatts

  • Newbie
  • *
  • Posts: 15
Ghost nodes
« on: April 05, 2020, 03:38:14 PM »
Since upgrading my Pi gateway to v9, I'm seeing "ghost nodes" reporting in my gateway a few times a week. By "ghost nodes", I mean node IDs that are not physically present in my RFM69 network. They show up only reporting their RSSI. I have been manually deleting them once a week or so.

I have not changed the sketch running on my USB Moteino that feeds into the gateway since I was running v8, but I am running a "non-stock" sketch on that Moteino to account for missing ACKs I had an issue with a year or two ago (see this topic https://lowpowerlab.com/forum/pi-gateway/gateway-does-not-receive-both-acks-from-paired-switchmotes/msg25985/#msg25985 ). I never saw any such false reportings using this modified sketch and gateway v8.

LukaQ

  • Sr. Member
  • ****
  • Posts: 301
  • Country: si
Re: Ghost nodes
« Reply #1 on: April 06, 2020, 04:10:19 AM »
That is probably a know problem, I have this too

But I unmarked in settings: genNodeIfNoMatch
now no new node is added by itself

gigawatts

  • Newbie
  • *
  • Posts: 15
Re: Ghost nodes
« Reply #2 on: April 07, 2020, 06:20:39 PM »
Ah, didn't know that was an option, I'll set that now, thanks!

It just seems strange that I never saw this behaviour in several years of using a gateway, now all of a sudden it's happening frequently.

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6279
  • Country: us
    • LowPowerLab

LukaQ

  • Sr. Member
  • ****
  • Posts: 301
  • Country: si
Re: Ghost nodes
« Reply #4 on: April 11, 2020, 01:51:17 AM »
I don't think so (should say I hope not), I get that on 868 also

Look below, as much nodes I could fit on screen and no, I don't have so many
most only have RSSI and no other metrics
« Last Edit: April 11, 2020, 01:54:15 AM by LukaQ »