Author Topic: Touchpad problem  (Read 779 times)

Mares

  • Newbie
  • *
  • Posts: 3
Touchpad problem
« on: March 28, 2020, 07:06:40 AM »
Hi,

i got CurrentRanger R3. So far so good. But i have the problem that the double touch is not working really good (Auto Range,BIAS,LPF).
I have to try 10 or 20times to touch both pads if it goes into Auto-Mode for example.

Is there a setup problem? Can a sensitivity change in the software fix the problem? Wrong parts on the board assembled?
Single contact to the touch pads is no problem. Only the simultanious touch.

I hope for help.
Thanks

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6279
  • Country: us
    • LowPowerLab
Re: Touchpad problem
« Reply #1 on: March 28, 2020, 09:11:53 PM »
I test each individual unit myself, and go through all the combinations, I never saw anything like that or I would change the touch sensitivity in the firmware.
What happens if you just touch one of the pads, then put your finger on the other? Is there a delay before it switches mode? Or it just doesn't work? What if you slightly moist your fingers?

Mares

  • Newbie
  • *
  • Posts: 3
Re: Touchpad problem
« Reply #2 on: March 29, 2020, 07:48:24 AM »
Mostly it doesn't work.

Take a look in the video.

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6279
  • Country: us
    • LowPowerLab
Re: Touchpad problem
« Reply #3 on: March 29, 2020, 12:40:06 PM »
Ok i see, is this the original firmware?

Mares

  • Newbie
  • *
  • Posts: 3
Re: Touchpad problem
« Reply #4 on: March 29, 2020, 03:11:56 PM »
Yes it is the original Firmware. I got it on Friday from Welectron. I think its a new batch.

Any Idea?

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6279
  • Country: us
    • LowPowerLab
Re: Touchpad problem
« Reply #5 on: March 29, 2020, 04:03:57 PM »
Can you contact me over email and I will try to help replace the firmware.
felix@lowpowerlab.com
Thanks

davidEnds

  • Newbie
  • *
  • Posts: 8
Re: Touchpad problem
« Reply #6 on: May 14, 2020, 07:25:06 AM »
Hi! I love my new current ranger but same problem here. Buy from Welectron and R3 version
« Last Edit: May 14, 2020, 07:31:40 AM by davidEnds »

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6279
  • Country: us
    • LowPowerLab
Re: Touchpad problem
« Reply #7 on: May 14, 2020, 02:23:11 PM »
davidEnds,
Which R3mk is it?
Can you connect just the CR to the USB, open a serial port and send 't', if you have latest firmware that should enable touchpad sensitivity debugging.

davidEnds

  • Newbie
  • *
  • Posts: 8
Re: Touchpad problem
« Reply #8 on: May 15, 2020, 08:02:45 AM »
R3 Mk4. Ok Ill try it :) Thks

davidEnds

  • Newbie
  • *
  • Posts: 8
Re: Touchpad problem
« Reply #9 on: May 15, 2020, 08:13:02 AM »
The LPF and BIAS works perfect when the USB is plugged. When I remove it, it doesn't work again

davidEnds

  • Newbie
  • *
  • Posts: 8
Re: Touchpad problem
« Reply #10 on: May 15, 2020, 02:13:43 PM »
Sorry, it just got back to work by plugging it into the usb and unplugging it again. What would be the explanation? Thanks for your time Felix

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6279
  • Country: us
    • LowPowerLab
Re: Touchpad problem
« Reply #11 on: June 15, 2020, 11:01:55 AM »
Sorry I completely missed the updates.
What output do you get when you type 't' with USB plugged?

See this line for that option, or send '?' for the menu options:  https://github.com/LowPowerLab/CurrentRanger/blob/master/CurrentRanger_R3.ino#L320

davidEnds

  • Newbie
  • *
  • Posts: 8
Re: Touchpad problem
« Reply #12 on: June 25, 2020, 10:56:44 AM »

The current ranger doesn't show me anything on the
serial monitor. But the touchpad works well again just by connecting it to the pc

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6279
  • Country: us
    • LowPowerLab
Re: Touchpad problem
« Reply #13 on: June 26, 2020, 07:28:12 PM »
You're probably opening the USB port too late.
However regardless of that, if you open the IDE's serial monitor and send a ? followed by ENTER, you should get the MENU shown up.
Ensure it is the CR serial port and not some other serial port.

davidEnds

  • Newbie
  • *
  • Posts: 8
Re: Touchpad problem
« Reply #14 on: June 28, 2020, 03:36:29 PM »
Thanks Felix!