Author Topic: After shutdown ATXraspi does not cut power [SOLVED: slow SD card]  (Read 1184 times)

sandro

  • NewMember
  • *
  • Posts: 4
Hello,

I installed ATXraspi on a raspberry Pi 3 model B and as i shutbown using the button the system does all the process but at the end ATXraspi does not cut the power.
I stay with the button LED ON and i cannot switch on again the system.
on ATXraspi shutdown is OFF and BOOTOK is weak green... yes not OFF and not normal Green, should be OFF.

One time worked with just connected the power and joypad cable. Then no more.

There is any solution for that?

Many thanks.

« Last Edit: June 17, 2017, 11:06:05 AM by Felix »

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6605
  • Country: us
    • LowPowerLab
Re: after shutdown ATXraspi does not cut power
« Reply #1 on: June 15, 2017, 12:53:17 PM »
Is your shutdowncheck.sh script running after boot?
Did BOOTOK come solid GREEN after boot?
Can I see a photo of your setup/wiring?

sandro

  • NewMember
  • *
  • Posts: 4
Re: after shutdown ATXraspi does not cut power
« Reply #2 on: June 15, 2017, 09:52:01 PM »
Hi. BOOTOK Is solid green when raspberry pi is ON.

Please see the photos and a video here
https://drive.google.com/open?id=0B2IBttez8FphUzktNlVTdVRQMTQ

I assume the script is ok since i can evoke the shutdown.

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6605
  • Country: us
    • LowPowerLab
Re: after shutdown ATXraspi does not cut power
« Reply #3 on: June 16, 2017, 10:21:47 AM »
THanks a lot, nice detailed photos and video.
The problem is your Pi takes forever to shutdown. The board waits around 50seconds for the shutdown to complete (BOOTOK to be turned OFF by Pi). If that does not happen in that much time, ATXRaspi does not know what is going on, and will keep power ON (for safety reasons, to avoid cutting power off when in fact something happens for a good reason and BOOTOK does not go LOW).

In all my testing and experience I never saw a Pi shut down so slowly, so that 50s delay was always a lot more than expected. Your Pi takes almost 70 seconds to shut down!
We can change that final delay in firmware to more. But how much is really reasonable without causing other problems?

If you return the board to me I can increase the final delay, or maybe you can try to improve the Pi to shut down faster?

sandro

  • NewMember
  • *
  • Posts: 4
Re: after shutdown ATXraspi does not cut power
« Reply #4 on: June 16, 2017, 12:05:32 PM »
This is a retropie fresh install. Do you have any suggestion to speed up the shutdown? Thanks for your support.

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6605
  • Country: us
    • LowPowerLab
Re: after shutdown ATXraspi does not cut power
« Reply #5 on: June 16, 2017, 12:16:56 PM »
Not really, but I never heard of this problem with a RetroPie, in fact I can't recall having problems with the 50s shutdown time window, otherwise I would have increased this before.
It seems like there's a lot of stuff going on at boot and at shutdown on your RetroPie, maybe look into disabling some of the packages/programs that take so long to stop.

sandro

  • NewMember
  • *
  • Posts: 4
Re: after shutdown ATXraspi does not cut power
« Reply #6 on: June 16, 2017, 03:22:43 PM »
fixed.
I switched the SD card (6.5 Mb/s) to one faster (8 Mb/s) and that's it.
Many thanks.