Author Topic: Running on eneloop AA batteries  (Read 4349 times)

ssmall

  • Full Member
  • ***
  • Posts: 147
  • Country: us
Running on eneloop AA batteries
« on: January 13, 2015, 09:26:15 AM »
I have had good luck using eneloop batteries.  -14*F last night and they are still going strong.

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6335
  • Country: us
    • LowPowerLab
Re: Running on eneloop AA batteries
« Reply #1 on: January 13, 2015, 09:33:12 AM »
Are you using rechargeable eneloops?

ssmall

  • Full Member
  • ***
  • Posts: 147
  • Country: us
Re: Running on eneloop AA batteries
« Reply #2 on: January 13, 2015, 10:12:28 AM »
Yes, I am using rechargeable AA eneloops.  They are the older version so I think they are 1600mAh.  I use 3 of them in series to power the weather station.  Looks like the latest eneloops are 2000mAh.

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6335
  • Country: us
    • LowPowerLab
Re: Running on eneloop AA batteries
« Reply #3 on: January 13, 2015, 10:54:45 AM »
Do you see a drop in voltage relative to the drop in temperature?
I would totally expect so, although not as dramatic as other cells.

ssmall

  • Full Member
  • ***
  • Posts: 147
  • Country: us
Re: Running on eneloop AA batteries
« Reply #4 on: January 13, 2015, 12:01:30 PM »
I do see a drop in voltage during really cold weather but it isn't much.  To be honest I am measuring the voltage using the moteinos built in voltmeter that others have referenced, so I don't think method truly reflects the actual voltage drop.  I have not tried to set up a proper voltage divider circuit to measure the actual battery voltage yet.

TomWS

  • Hero Member
  • *****
  • Posts: 1925
Re: Running on eneloop AA batteries
« Reply #5 on: January 13, 2015, 12:47:25 PM »
I do see a drop in voltage during really cold weather but it isn't much.  To be honest I am measuring the voltage using the moteinos built in voltmeter that others have referenced, so I don't think method truly reflects the actual voltage drop.  I have not tried to set up a proper voltage divider circuit to measure the actual battery voltage yet.
Do you mean that you are using measuring the 1.1V reference voltage and extrapolating the VCC from that?  If so, that's fairly accurate, even over temperature.

Tom

ssmall

  • Full Member
  • ***
  • Posts: 147
  • Country: us
Re: Running on eneloop AA batteries
« Reply #6 on: January 13, 2015, 12:53:47 PM »
Tom, that is what I am doing.  If that is correct, I am seeing voltage drops on the order of 100ths of volts on days where the temp is below zero F.

TomWS

  • Hero Member
  • *****
  • Posts: 1925
Re: Running on eneloop AA batteries
« Reply #7 on: January 13, 2015, 04:44:31 PM »
Tom, that is what I am doing.  If that is correct, I am seeing voltage drops on the order of 100ths of volts on days where the temp is below zero F.
WOW, that's pretty outstanding!  Makes me want to switch to these!  But wait... they don't spec these to work below 0 degrees C!  What's up?  I sure wish they'd spec what these are 'supposed' to do in 'normal' outdoor cold conditions.  -15F spec would be very useful.

1.2V is a problem unless I make a cylindrical battery holder that would hold three of them...
Wikipedia page states that early versions of their C and D cells were just that, three of the A type batteries in parallel.

Anybody seen a cylindrical 3xAAA holder???Nevermind, I just designed one to cut out on my CNC router!  8)  Unless, of course, you HAVE seen a holder like this (in which case I'll buy instead of build)!

Thanks for the info.
Tom

ssmall

  • Full Member
  • ***
  • Posts: 147
  • Country: us
Re: Running on eneloop AA batteries
« Reply #8 on: January 13, 2015, 10:05:55 PM »
I looked on the eneloop site about year ago and as I recall it said they were good down to -20*C.  I could be mistaken.  I have not seen any holders like you describe.  I do have the plastic C and D battery holders that you can insert a AA battery.  Not that useful.  Wish I had a CNC router!  ;D

TomWS

  • Hero Member
  • *****
  • Posts: 1925
Re: Running on eneloop AA batteries
« Reply #9 on: January 13, 2015, 11:15:23 PM »
<...snip>Wish I had a CNC router!  ;D
Build one!  That's what I did.  Check out http://www.solsylva.com/

Tom
BTW, which battery website had the -20C info?

ssmall

  • Full Member
  • ***
  • Posts: 147
  • Country: us

TomWS

  • Hero Member
  • *****
  • Posts: 1925
Re: Running on eneloop AA batteries
« Reply #11 on: January 14, 2015, 03:31:21 PM »
http://www.panasonic-eneloop.eu/home/whats-eneloop.html
Thanks. ::)
I can visualize that marketing guy giving the 'specs' to the webpage developer and it slipped his mind to tell the engineer who wrote the datasheet...   Probably too busy thinking about his next golf outing with a customer.

Sigh...

kiwisincebirth

  • Jr. Member
  • **
  • Posts: 69
Re: Running on eneloop AA batteries
« Reply #12 on: January 16, 2015, 11:13:44 PM »
Here is my last year (sort of) on 3xAA envelop batteries. I say sort of because I have composed it from six months of data from four different nodes that started at different voltages.

All nodes have a simple voltage divider (few meg ohms) to measure the input battery voltage. All nodes also power a DS18B20 temp sensor, except node 12 which has a Lux meter. All nodes wake up every minute and transmit a reading. I am Sydney, Australia so ambient temps are good.

I am hoping to get about 1.5 - 2 years from a single charge, but will see.

The graph shows number of days on the bottom axis, and volts on the side.

TomWS

  • Hero Member
  • *****
  • Posts: 1925
Re: Running on eneloop AA batteries
« Reply #13 on: January 17, 2015, 08:35:50 AM »
Kiwi,
thanks for sharing!  This is GREAT and perfect timing for me.  I've been considering switching to these (from LiPos) as battery backup for my Gateways but was concerned at how fast they'd drain to 1.2 volts.  It seems from your data that, with minimal discharge, their voltage stays on the high side for a long time.  I think you'll get far more than two years because they are only now reaching their plateau level (nominal 1.2V). 

I just need to look into charging circuits before I make my 'leap'.

Thanks again!
Tom

kiwisincebirth

  • Jr. Member
  • **
  • Posts: 69
Re: Running on eneloop AA batteries
« Reply #14 on: February 19, 2015, 03:29:57 PM »
Hi There. Here is my first eneloop crash. Was fairly liner down to 3.6v (mid jan) then fall sharply to 3.3v Interesting is what happened when it reach 3.3v Node is still running fine. Thoughts ?
« Last Edit: February 19, 2015, 04:10:57 PM by kiwisincebirth »

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6335
  • Country: us
    • LowPowerLab
Re: Running on eneloop AA batteries
« Reply #15 on: February 19, 2015, 03:35:20 PM »
I think around 3.6v is where you enter that regulator dropout region where it's trying really hard to supply the output voltage and it's eating a lot more power because of that and that's why the graps is dropping dramatically after 3.6V.

TomWS

  • Hero Member
  • *****
  • Posts: 1925
Re: Running on eneloop AA batteries
« Reply #16 on: February 19, 2015, 04:14:20 PM »
Hi There. Here is my first eneloop crash. Was fairly liner down to 3.6v (mid jan) then fall sharply to 3.3v Interesting is what happened when it reach 3.3v Node is still running fine. Thoughts ?
3.6 volts is where 3 ENELOOPs in series would hit the knee - 1.2V each.  While it may have taken a temporary slow down (maybe due to reduced current) at 3.3V, I'd expect the battery to continue to decay until the mote stops operating.

Re Felix's explanation, I'm not sure about that.  Given that it's not a bipolar regulator, the controls would be voltage driven, not current driven, so 'trying harder' doesn't seem correct to me.  Still, I'll take a look at the regulator spec and see if they even spec current near the dropout voltage.

You're currently in your Summer months, right?  What's the ambient temperature?

Tom

kiwisincebirth

  • Jr. Member
  • **
  • Posts: 69
Re: Running on eneloop AA batteries
« Reply #17 on: February 20, 2015, 12:08:34 AM »

You're currently in your Summer months, right?  What's the ambient temperature?

Tom
Yes end of summer, In the last week Max = 28, down to 19 degrees C at night. Will see how much longer it lasts and report back latter.

TomWS

  • Hero Member
  • *****
  • Posts: 1925
Re: Running on eneloop AA batteries
« Reply #18 on: February 20, 2015, 12:49:41 AM »
Your latest curve is intriguing - that it's totally flat once it reached 3.3V.  What circuit and what code are you using to measure the voltage?

Tom

kiwisincebirth

  • Jr. Member
  • **
  • Posts: 69
Re: Running on eneloop AA batteries
« Reply #19 on: February 20, 2015, 01:13:32 AM »
Your latest curve is intriguing - that it's totally flat once it reached 3.3V.  What circuit and what code are you using to measure the voltage?

Tom
I have 2 x 1Mohm as a voltage divider with a 0.1uf capacitor as per the following post.

http://jeelabs.org/2013/05/16/measuring-the-battery-without-draining-it/

The code (except) is below, basically it just does and analogRead() and computes and publishes a voltage, this is called once a minute. I haven't posted this on GitHub - yet.

Kiwi

Code: [Select]
#define VOLTAGE          3.3 // Motes run on DC 3.3V

/**
 * Main Publish Battery Function
 */
void publishBattery() {
 
  // the pin is defined based on configuration.
  static byte pin = A0 + configuration.batteryAPin;
 
  // what is the voltage. "batteryFactor" is configured as 0.5 (i.e. resistor divider), 1000 reports in miliVolts
  batteryVoltage = readVoltage( pin ) / configuration.batteryFactor * 1000.0f;
 
  // sent the battery voltage, this packages and sends a RFM69 packet.
  sendPublishMessage( MEASURE_BATT_MV, batteryVoltage );
}

/**
 * the analog volatge from an analog input pin
 */
float readVoltage( int sensorPin ) {
 
  // make sure iys an input pin
  pinMode( sensorPin, INPUT);
 
  // read and discard once
  analogRead(sensorPin);
 
  // Volatage = Reading / 1023 {magnitude of reading} * 3.3 {volts that the reading represents}
  return VOLTAGE * ( analogRead(sensorPin) + analogRead(sensorPin) ) / 2 / 1023;
}

TomWS

  • Hero Member
  • *****
  • Posts: 1925
Re: Running on eneloop AA batteries
« Reply #20 on: February 20, 2015, 08:25:16 AM »
Your latest curve is intriguing - that it's totally flat once it reached 3.3V.  What circuit and what code are you using to measure the voltage?

Tom
I have 2 x 1Mohm as a voltage divider with a 0.1uf capacitor as per the following post.

http://jeelabs.org/2013/05/16/measuring-the-battery-without-draining-it/

The code (except) is below, basically it just does and analogRead() and computes and publishes a voltage, this is called once a minute. I haven't posted this on GitHub - yet.

Kiwi

Code: [Select]
#define VOLTAGE          3.3 // Motes run on DC 3.3V

/**
 * Main Publish Battery Function
 */
void publishBattery() {
 
  // the pin is defined based on configuration.
  static byte pin = A0 + configuration.batteryAPin;
 
  // what is the voltage. "batteryFactor" is configured as 0.5 (i.e. resistor divider), 1000 reports in miliVolts
  batteryVoltage = readVoltage( pin ) / configuration.batteryFactor * 1000.0f;
 
  // sent the battery voltage, this packages and sends a RFM69 packet.
  sendPublishMessage( MEASURE_BATT_MV, batteryVoltage );
}

/**
 * the analog volatge from an analog input pin
 */
float readVoltage( int sensorPin ) {
 
  // make sure iys an input pin
  pinMode( sensorPin, INPUT);
 
  // read and discard once
  analogRead(sensorPin);
 
  // Volatage = Reading / 1023 {magnitude of reading} * 3.3 {volts that the reading represents}
  return VOLTAGE * ( analogRead(sensorPin) + analogRead(sensorPin) ) / 2 / 1023;
}
That's what I suspected.  This will ALWAYS read around 3.3V even if the battery is 2.5 volts.  Why?  Because your voltage reference, VDD, is tracking the measured voltage.  The measuredVoltage will always read 0.5 of VDD...  You need a correction factor that measures VDD compared to the internal 1.1V reference such that BatteryVoltage = (MeasuredVDDmV/3300)*(calculatedBatteryVoltage)...

UPDATE: You could also measure your battery against the 1.1V reference but that would require hardware changes (to divide to less than 1.1V) and it's useful to read VDD anyway.

Tom
« Last Edit: February 20, 2015, 10:19:49 AM by TomWS »

kiwisincebirth

  • Jr. Member
  • **
  • Posts: 69
Re: Running on eneloop AA batteries
« Reply #21 on: February 20, 2015, 04:43:21 PM »
Tom thanks, I understand your point, but am happy with the solution I have at the moment, basically I just need pre warning when a node is about to die. And BtW the node did die in the last day.

Kiwi

TomWS

  • Hero Member
  • *****
  • Posts: 1925
Re: Running on eneloop AA batteries
« Reply #22 on: February 20, 2015, 06:16:24 PM »
Tom thanks, I understand your point, but am happy with the solution I have at the moment, basically I just need pre warning when a node is about to die. And BtW the node did die in the last day.

Kiwi
I think your indication that it's about to die is when it flatlines to 3.3V  :)

So, now that you've successfully used up your charge on the Eneloops, how do you like them? 

Tom

kiwisincebirth

  • Jr. Member
  • **
  • Posts: 69
Re: Running on eneloop AA batteries
« Reply #23 on: February 22, 2015, 08:05:27 PM »
I think your indication that it's about to die is when it flatlines to 3.3V  :)

So, now that you've successfully used up your charge on the Eneloops, how do you like them? 

Tom
Correct, <3.6V is advance notice, <3.4v expect it to die soon.

I think I choose them because of ease of maintenance. I have an apple charger which you just plug these into. A Lipo (my reading) needs a special charger circuit, and I have read numerous report of them being affect by low temperatures. Sydney does drop down to a few degrees above zero at night in winter months, so I saw this as a more reliable option.

Getting 1-2 years off a single charge is perfectly adequate solution, and could very easily extended by reducing the frequency of sampling and transmitting data.


TomWS

  • Hero Member
  • *****
  • Posts: 1925
Re: Running on eneloop AA batteries
« Reply #24 on: February 22, 2015, 09:37:52 PM »
Correct, <3.6V is advance notice, <3.4v expect it to die soon.

I think I choose them because of ease of maintenance. I have an apple charger which you just plug these into. A Lipo (my reading) needs a special charger circuit, and I have read numerous report of them being affect by low temperatures. Sydney does drop down to a few degrees above zero at night in winter months, so I saw this as a more reliable option.

Getting 1-2 years off a single charge is perfectly adequate solution, and could very easily extended by reducing the frequency of sampling and transmitting data.
It would be a pretty simple software mod to know, exactly, what you're battery voltage is.  If you compensate with the VDD reading, then, as long as VDD is 3.3V (ie, the batteries are supplying enough voltage for the regulator to be operating within its control range) then your direct reading will be accurate, but once your VDD reading starts dropping off, then the scaled reading will still give you an accurate reflection of battery state.

Having said that, though, these batteries knee pretty sharply at 1.2V so, as you say, once you're down to 3.4V, you're toast!

I agree with you about the scariness of LiPo charging.  If you don't have a temperature compensated protector circuit, you're asking for trouble!

I was looking at 18650s and, while mechanically more robust than LiPos, they don't normally come with the protection circuit.  I've found a few breakouts that look interesting, but, it's tough to beat a couple of lithium primary cells for remote Motes...  As long as you can live with dialing back the processor speed to 8MHz (which virtually all of my Motes can tolerate).

The only place I've found a use for rechargeables is the battery backup for my gateway.  Using LiPos there, but with protection circuit and constant monitoring of battery voltage, with load, even while on mains.

Tom