Author Topic: Raspi Gateway Garagemote can't connect from Internet  (Read 1444 times)

megasis

  • Newbie
  • *
  • Posts: 15
Raspi Gateway Garagemote can't connect from Internet
« on: April 27, 2015, 12:00:27 AM »
I started a couple of weeks ago, to work on controlling monitoring my Garage Door when I'm away using my iPhone.  I found LowPowerLap and that was the answer, I got me a Raspberry PI 2, 2 moteino w/ RFM69W and Flash and 1 without flash (for the gateway), I also got the ATXRasPi and a couple of FTDI Adapters for testing.
First I follow step by step the software installation for the nodes (moteino sketches), then I installed the sensors and the GarageMote and test it using a Serial Console (with out Rasp PI) and worked fine.

The next step was putting all together, the Moteino Gateway, the ATXRaspi, the Power Switch and the Rasp PI, I can shutdown and restart fine using just the Power Switch, I also was able to  to test the communication between the nodes and the PI, worked too, I used my 3rd Moteino with the node.ino scketch and I was able to see the characters  coming from the serial port using PuTTY. 
Then I installed all the software needed in the Raps PI following the instruction on the webpage (nginx, node, npm, serialport, chat.js, gateway.js, etc), and all is working fine from inside my house (my Intranet), I get see the Garage Status, I can Open and Close from my Browser, see the log. I can also get the Gateway page from my iPhone when connected WiFi to my home network. :D

Then I set up my router to Forward Port 80 to the Raspberry PI IP Address, and I disconnected my iPhone from my WiFi network and try to get the Gateway Page from internet, but I only get the error:
"Safari could not open the page because the server stopped responding"   :'(

I don't understand what can be wrong, I followed all the instructions from LowPowerLap blogs "Projects Garage Mote" and "RaspberryPi home automation gateway" to the letter.

Am I missing something? :-\ I suppose to connect to the Gateway from the internet, right?

Thanks in advance for all your help on this,

Maximo

megasis

  • Newbie
  • *
  • Posts: 15
Re: Raspi Gateway Garagemote can't connect from Internet
« Reply #1 on: April 27, 2015, 12:22:15 AM »
My Bad  ;D , It is working Now  8) , I forgot to Forward Port 443 too. :)

Now I just need to make the page a little friendly for the iPhone, the Buttons are too big and a lot of RED buttons I don't use, but It works!!!  :D

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6404
  • Country: us
    • LowPowerLab
Re: Raspi Gateway Garagemote can't connect from Internet
« Reply #2 on: April 27, 2015, 08:27:06 AM »
I will release the new Gateway interface (hopefully this week) and that will be a lot more fun to play with.

TomWS

  • Hero Member
  • *****
  • Posts: 1925
Re: Raspi Gateway Garagemote can't connect from Internet
« Reply #3 on: April 27, 2015, 10:31:19 AM »
...and that will be a lot more fun to play with.
Only a certified Geek could say this and mean it...  :D

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6404
  • Country: us
    • LowPowerLab
Re: Raspi Gateway Garagemote can't connect from Internet
« Reply #4 on: April 27, 2015, 12:58:03 PM »
I forgot to mention that is according to me and at least a few folks that have given positive feedback to the blog post and video I published a 10 days ago:


megasis

  • Newbie
  • *
  • Posts: 15
Re: Raspi Gateway Garagemote can't connect from Internet
« Reply #5 on: April 30, 2015, 04:19:36 PM »
I'm looking forward to the new gateway since I saw the video, it looks truly amazing, specially the fact that's configurable, event driven, auto detect nodes, graphs, email, Text... and with nice graphics  8).
I'll be checking for the release. ;)
Thanks