Author Topic: "no log data" gateway dashboard - POST ERROR: ENOENT [SOLUTION]  (Read 503 times)

SanG

  • NewMember
  • *
  • Posts: 43
"no log data" gateway dashboard - POST ERROR: ENOENT [SOLUTION]
« on: February 26, 2019, 11:58:09 AM »
I am currently working on monitoring solar radiation data. I don't have any problem in collecting the pyranometer's raw output voltage (mV) data but I do have an issue with collecting solar radiation (W/m2) data. I have my Pi gateway set up in such a way that it collects various data including the above two: i) raw output voltage (mV) and ii) solar radiation (W/m2). Although Ithe gateway is updating the solar radiation (W/m2) data each time the node transmits the graph is not showing anything and it says "no log data" at the top left (see screenshot). This is the first time I have ever encountered this type of issue. Searched in google but couldn't find the relevant issue and the solution. Please help.
« Last Edit: February 26, 2019, 01:30:16 PM by Felix »

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6571
  • Country: us
    • LowPowerLab
Re: "no log data" moteino gateway dashboard..
« Reply #1 on: February 26, 2019, 12:14:59 PM »
Check gateway.sys.log for any errors.
I would try to clear the binary file for that particular metric.

SanG

  • NewMember
  • *
  • Posts: 43
Re: "no log data" moteino gateway dashboard..
« Reply #2 on: February 26, 2019, 12:44:46 PM »
Hello Felix,
Thanks for such a prompt reply. I checked it and found that a repeating error that says:
[02-24-19_06:25:29.564] [ERROR]    POST ERROR: ENOENT: no such file or directory, open '/home/pi/gateway/data/db/0099_Solar Radiation (W/m2).bin'.
There are binary files for all other remaining metrics but couldn't find the file for that metric to delete.

Thanks

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6571
  • Country: us
    • LowPowerLab
Re: "no log data" moteino gateway dashboard..
« Reply #3 on: February 26, 2019, 12:59:25 PM »
Error is self explanatory, likely because of the chars in the name.
I think you should try to rename the node/metric and exclude any special characters.
A possible fix in a future version will be to do that automatically when creating the db binary files.

SanG

  • NewMember
  • *
  • Posts: 43
Re: "no log data" moteino gateway dashboard..
« Reply #4 on: February 26, 2019, 01:29:06 PM »
 Great! It worked. I think it was the "/" in the metric name "Solar Radiation (W/m2)", as per your suggestion I renamed it to "Solar Radiation (Wm2)" and it is working now. 

Thank you Felix.