Author Topic: measuring issue  (Read 191 times)

Alp

  • NewMember
  • *
  • Posts: 2
measuring issue
« on: April 03, 2021, 03:46:24 PM »
Hello,
My CurrentRanger constantly shows 0 when DUT connected (.0 digit is blinking).
DMM measure correctly 125uA.

CurrentRanger connection:
DUT power supply was connected to the 'Supply+' connector.
DUT was connected to 'DUT+' connector.
CurrentRanger powered from usb connected to my laptop.

Where is the problem.

Thanks,
Al.

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6531
  • Country: us
    • LowPowerLab
Re: measuring issue
« Reply #1 on: April 05, 2021, 11:01:34 AM »
You may be damaging the CR if you power from a power supply that is non isolated common ground to your USB.
Read the guide instructions and safety page, and make sure you power it properly as described in the guide.

https://lowpowerlab.com/guide/currentranger/

Alp

  • NewMember
  • *
  • Posts: 2
Re: measuring issue
« Reply #2 on: April 05, 2021, 02:19:11 PM »
I see...
Can I send back CR to the lab for repair?
Or maybe you can guide me how to fix the broken CR by myself.

Thanks.

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6531
  • Country: us
    • LowPowerLab
Re: measuring issue
« Reply #3 on: April 05, 2021, 02:21:54 PM »
Please follow the guide, connect it correctly with a battery inside the unit.
Then evaluate if something is still wrong. I have not seen a fried CR in a long time, I'd like to think it can withstand the type of use you just described.