Author Topic: ATXRaspi doesn't activate powerbank  (Read 1278 times)

icehawk

  • Newbie
  • *
  • Posts: 8
ATXRaspi doesn't activate powerbank
« on: December 26, 2018, 04:42:34 PM »
Hello everyone,

I have a similar problem like this one https://lowpowerlab.com/forum/atxraspi/circuit-that-will-wake-battery-activate-atxraspi/ but I have the problem that my powerbank does not have a button to activate it. The powerbank activates itselfs if there is a consumer connected

I builded a musicbox for my daugther. Here are some pics https://forum-raspberrypi.de/forum/thread/13144-projekt-jukebox4kids-jukebox-fuer-kinder/?postID=359776#post359776

The ATXRaspi is working fine when the power adapter is plugged in the socket. My aim is to use the integrated powerbank (https://www.amazon.de/gp/product/B015CIZEF0/ref=oh_aui_detailpage_o04_s00?ie=UTF8&psc=1) for the power supply. When the ATXRaspi ist connected with the powerbank and I press the button which is connected to the ATXRaspi the powerbank will not be activated and the pi does not power up.

My idea was to add an LED as a new consumer to one of the two USB outputs with a switch to activate the powerbank. This is working fine (picture 20181226_223102.jpg)
As soon as I connect the ATXRaspi to the second USB output the LED does'nt glow if I press the button (picture 20181226_223043.jpg).
When the powerbank is active and i connect the ATXRaspi I can press the button for the led and it is glowing (picture 20181226_223127.jpg).

I tried some different wiring by using only one USB outpunt and the input of "2.1mm Jack" but without success (picture  20181226_223443.jpg).

Does anybody has an idea why my idea is not working or a different way to solve my problem?

Kind regards
Icehawk



« Last Edit: December 26, 2018, 04:48:03 PM by icehawk »

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6022
  • Country: us
    • LowPowerLab
Re: ATXRaspi doesn't activate powerbank
« Reply #1 on: December 26, 2018, 05:15:56 PM »
The ATXRaspi uses a few mA on its own. When you connect power to it (5V) it should blink the RED led (as of R 2.8), either once (momentary operation) or twice (latching).
Then you know you're ready to power up loads from the ATXRaspi.
I don't see a button connected to the ATXRaspi in your setup.... nor do I see a LOAD. How do you plan to turn anything on using ATXRaspi?

icehawk

  • Newbie
  • *
  • Posts: 8
Re: ATXRaspi doesn't activate powerbank
« Reply #2 on: December 26, 2018, 05:29:28 PM »

Hello Felix,
thanks for your quick response.

When I connect power the red LED is flashing one time as you described.

Here are three pics how the ATXRaspi is integrated in my musicbox.
In the picture one and two I used an external power adapter. Power up and shutdown is working fine.
In the third picture I connected my powerbank. When I press the switch nothing happens.

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6022
  • Country: us
    • LowPowerLab
Re: ATXRaspi doesn't activate powerbank
« Reply #3 on: December 27, 2018, 12:06:14 PM »
In the third picture I connected my powerbank. When I press the switch nothing happens.
I suspect your power bank does not power the ATXRaspi, because it might not sense enough currect being drawn.
Does the red LED blink when you connect the power bank?

Also, you have very long wires, I cannot really clearly see what's connected to what, I assume from your description the ATXRaspi is powering your Pi and BOOTOK and SHUTOFF signals are also connected correctly.
Especially for the 5V wiring that powers the Pi, that should be good wire and as short as possible.

icehawk

  • Newbie
  • *
  • Posts: 8
Re: ATXRaspi doesn't activate powerbank
« Reply #4 on: December 27, 2018, 01:23:02 PM »
I just made a minimal setup to make sure the cable are as short as possible. The four wires from the ATXRaspi to the Pi I ordered together with the ATXRaspi board.
In the first picture the ATXRaspi is connected to the external power adapter and everything is fine.
In the second picture I only connected the ATXRaspi to the powerbank. The red light is flashing one time and the status leds of the powerbank are glowing.
In the third picture I waited until the status leds are switched off and then I pressed the button but nothing happened.

icehawk

  • Newbie
  • *
  • Posts: 8
Re: ATXRaspi doesn't activate powerbank
« Reply #5 on: December 27, 2018, 02:37:19 PM »
Another point I saw during testing:
- Plug ATXRaspi (without any cables) to Powerbank
- Wait status leds switch off
- connect Smartphone to the powerbank
Result: The Smartphone will not be charged. The status leds of the powerbank are off

When I only plug my Smartphone to the powerbank it will be charged and the status leds of the powerbank are active

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6022
  • Country: us
    • LowPowerLab
Re: ATXRaspi doesn't activate powerbank
« Reply #6 on: December 27, 2018, 07:07:21 PM »
Quirky power bank  :-\
What does it mean when the status LEDs of the power bank go off?

icehawk

  • Newbie
  • *
  • Posts: 8
Re: ATXRaspi doesn't activate powerbank
« Reply #7 on: December 28, 2018, 04:52:55 PM »
When the status LEDs go off the powerbank doesn't charge connected devices.

I just ordered a different powerbank and hope the next one will work. I will post a feedback when I receive the new powerbank.

icehawk

  • Newbie
  • *
  • Posts: 8
Re: ATXRaspi doesn't activate powerbank
« Reply #8 on: January 01, 2019, 01:28:31 PM »
Yesterday the new powerbank "EasyAcc 20000mAh Externer Akku PowerBank mit 4 USB Ausgängen" arrived and I made some test with this powerbank and the ATXRaspi.

1. Testcase
- Connect ATXRaspi with the powerbank
- Red light on the ATXRaspi is flashing 1x
- Push button to power up raspberry pi a few seconds after ATXRaspi was connected to the powerbank
- Pi is runnig and everything is fine

2. Testcas
- Push button for 2 sec. to shutdown pi
- LEDs of powerbank are off after round about 5 seconds
- Wait 1 min.
- Push button to power up the pi over ATXRaspi
- Nothing happens :-(
- The LEDs on the powerbank are off

3. Testcase
- Connect mobile phone Samsung S5 to the powerbank
- mobile phone is charged by powerbank and status LEDs on powerbank are on
- ATXRaspi ist still connected to the powerbank (like in Testcase 1)
- Push button to power up raspberry pi over ATXRaspi
- Nothing happens :-(

At the moment I don't have any more ideas how to use the ATXRaspi with a powerbank. Is anyone using the ATXRaspi with a powerbank with the use case power up and power down a raspberry pi 3b?

I don't know if I have a just bad powerbanks or if I have a bad sample of the ATXRaspi. I had in minimum expected as a result of Testcase 3 that the pi would power up.

« Last Edit: January 01, 2019, 04:31:05 PM by icehawk »

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6022
  • Country: us
    • LowPowerLab
Re: ATXRaspi doesn't activate powerbank
« Reply #9 on: January 02, 2019, 02:45:48 PM »
Reading through your test #1 and #2 tells me your power bank is cutting power in some way after it senses the load is "disconnected". In our case it's not really off, the ATXRaspi still runs and uses a few mA. Why test#3 doesn't work is a mistery, maybe the thing can't supply enough power or is regulating it in some way (i would be surprised if so), or it just enters some kind of constant current state. I would totally expect hooking up something else to it would also work.
So there's nothing wrong with the ATXRaspi, it works as it should based on your first tests, but it won't work if the power supply to it goes dead or is cut off. The way you can verify this, is by providing a continuous 5V from a 2A Pi power supply.

I think someone else reported something similar, these power banks sense when the load is "disconnected" and turn off their internal booster (which is probably not the most efficient) to extend their "off state" battery life, are they advertised as some kinda "intelligent" power bank?

You could use a MightyHat which has a booster and allows you to run from any size LiPo you want, recharge it while Pi is running...

icehawk

  • Newbie
  • *
  • Posts: 8
Re: ATXRaspi doesn't activate powerbank
« Reply #10 on: January 06, 2019, 03:11:14 PM »
I found a soloutin for my problem.

I ordered this little board: https://forum-raspberrypi.de/forum/thread/28272-powerbank-zur-versorgung-kleiner-lasten-nutzen-grundlast-fuer-powerbank/ from the user "Neueinsteiger"
This little board is connected to one usb port of the powerbank and it will consume every 5s 200mA. With this "hack" the powerbank doesn't go to sleep and I can use the ATXRaspi Board  :)

At the moment it is not a problem for me if the powerbank is "always on". For the future I think I will include a switch to disconnect the little usb Adapter to let the powerbank fall asleep.

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6022
  • Country: us
    • LowPowerLab
Re: ATXRaspi doesn't activate powerbank
« Reply #11 on: January 06, 2019, 05:49:40 PM »
Good to know there's a solution. Thanks for the follow-up.
How interesting, someone even came up with a circuit to keep these power banks from sleeping, it must be that they behave the same. Chinese right?
So I was right :)

icehawk

  • Newbie
  • *
  • Posts: 8
Re: ATXRaspi doesn't activate powerbank
« Reply #12 on: January 07, 2019, 05:38:39 PM »
Until now I just tested it with the EasyAcc powerbank. When there is some free time I will have a look if it is working with the Intenso Powerbank, too.
What do you mean with "Chinese right?"

Felix

  • Administrator
  • Hero Member
  • *****
  • Posts: 6022
  • Country: us
    • LowPowerLab
Re: ATXRaspi doesn't activate powerbank
« Reply #13 on: January 07, 2019, 05:45:40 PM »
I meant, "made in china"?